Issues syncing data from local SQL to Azure SQL

  • 15Views
  • Last Post 01 April 2019
Troy Theobald posted this 28 March 2019


We are trying to demo your product and it is failing the initial sync with error ;"3849";"i";"Cannot insert the value NULL into column 'CustNum'.

Out goal is to sync tables from an on-site SQL to Azure SQL tables.  An example local table is x.customer and the remote table is x.customer.

We got errors when trying to set up a sync package.  After changing to an auto-generated ID we get the following error, even after allowing NULL values for all columns.

"table 'kbmax_prod_stellar_test.x.CustomerX'; column does not allow nulls. INSERT fails."

UPDATE:   Tried to do an Import task using the 'update' option.  Now it shows successful and the logs indicate so, but nothing shows up in the target table. 

UPDATE:  Tried changing the import task to 'Insert' and it failed.   Tried changint it to 'UPSERT' and now I reached my 5000 record limit for the free trial version but I'm yet to actually move anything to the Target database.  Can this be reset while I try to get it working?


Thank you

Mariia Zaharova posted this 01 April 2019

We have contacted you by email. 


Best regards,