A connection attempt failed connected party did not properly respond after a period of time

  • 36Views
  • Last Post 5 weeks ago
  • Topic Is Solved
0
votes
Kaja Leligdowicz posted this 15 January 2020

Hi, I've been trying to connect Skyvia with PostgreSQL (Mac OS) and I've been getting the following issues:

First of all, I've been getting this message “skyvia postgresql connection could be made because the target machine actively refused it” when trying to connect with "local host"

I've done some troubleshooting and run the issue with Python and psycopg2. It connected with the PostgreSQL, which confirms it is not an issue with the firewall (switched off) or the Mac itself which could have not allowed for the connection (everything is open and it connects). 

Nonetheless, the Skyvia still cannot connects with the PostgreSQL. Having tried the server "192.168.1.248" I go the following message :  "A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond" 

Any ideas how can I solve this issue? 

I have already gone through multiple pages and various ideas - edited the pg_hba.conf and postgresql.conf to enable the connection and restarted relevant databases.

Order By: Standard | Newest | Votes
0
votes
Dmitriy Muzurov posted this 16 January 2020

Hello Kaja,

Thank you for submitting a ticket with us.

There are three PostgreSQL connections in your account and two of them fail with this error:

No connection could be made because the target machine actively refused it 127.0.0.1:5432

127.0.0.1 refers to localhost and 192.168.1.248 is a private IP address that can be used by anyone in their internal networks. You need to specify a public IP address which your PostgreSQL server can be accessed by.

We also tested your third connection and it failed with "Timeout expired". If a public IP address is specified for this particular connection, we can advise to increase Connection Timeout parameter in the Advanced parameters for PostgreSQL in your Skyvia account.

Please check this link for connecting PostgreSQL in regular Skyvia and this one for connecting PostgreSQL in Skyvia New.

We are looking forward to hearing from you, should you have any questions.

0
votes
Kaja Leligdowicz posted this 5 weeks ago

Thank you for the prompt reply, Dimitriy.

I tried your solutions before. unfortunately they did not solve the issue, but I think I might have not explained the situation clearly.

Is it the case that the data warehouse (PostgreSQL in this case) one is trying to connect the initial database (Sugar CRM in my case) to, should be online, just as sugar crm, as opposed to having the PostgreSQL on the computer?

0
votes
Dmitriy Muzurov posted this 5 weeks ago

Dear Kaja,

Thank you for getting back to us.

PostgreSQL server must be online and publicly accessible for Skyvia. The connection is made from this IP address: 40.118.246.204

Here is the guide on how to configure PostgreSQL for remote access.

If the issue with 'Timeout expired' error message repeats, we would advise you to set the Connection Timeout parameter to 0. Should it persist, check if your PostgreSQL is configured correctly as well as firewall.

Feel free to contact us back, should you have any questions.

Close