Date fields query as '1-1-0001' even though data in source environment (ZOHO) displaying correctly

  • 468Views
  • Last Post 22 April 2019
0
votes
Sachin Dabrein posted this 04 February 2019

Hello,

We are trying to integrate data from Zoho to an Azure Database. Several records keep failing due to the error 'SqlDateTime overflow. Must be between 1/1/1753 12:00:00 AM and 12/31/9999 11:59:59 PM.'. When we query the data from Skyvia, we can see the date fields in question displaying '1/1/0001' for those records, however, those records display the correct dates in Zoho. Could you kindly let us know if there is any way to query the correct dates?

Best Regards,

Simran

Order By: Standard | Newest | Votes
0
votes
Sachin Dabrein posted this 22 April 2019

Thanks Mariia.

I tried with export data. 

I have tested with the replicate maps and it is working fine. 

Thank you again Mariia. 

This issue got resolved after long time. 

 

Thanks, 

Sachin Dabre

 

 

0
votes
Mariia Zaharova posted this 22 April 2019

What exactly steps did you perform and with what exactly package? Did you perform full replication? Whether date time format parameter is correct?

 

We are getting expected results at the moment, both in Query Tool and Replication package. 

 

Best regards,

Mariia

0
votes
Sachin Dabrein posted this 22 April 2019

Hi Mariia, 

I am still facing the same issue for From and To date feilds of Zoho people. 

 

Thanks,

Sachin

0
votes
Sachin Dabrein posted this 22 April 2019

Thank you Mariia.

I will check and will update you. 

 

Thanks, 

Sachin

0
votes
Mariia Zaharova posted this 22 April 2019

Hi Sachin!

 

We updated Skyvia. Please try again and let us know the results.

 

Best regards,

Mariia

0
votes
Mariia Zaharova posted this 19 April 2019

Hi Sachin!

 

We plan to update Skyvia early next week.

 

Best regards,

Mariia

0
votes
Sachin Dabrein posted this 19 April 2019

Hi Mariis, 

Kindly update regarding Skyvia update.

 

Thnaks,

Sachin

0
votes
Mariia Zaharova posted this 10 April 2019

Hi Sachin!

 

We have fixed the issue. I will post here when Skyvia is updated.

 

Best regards,

Mariia

0
votes
Mariia Zaharova posted this 08 April 2019

Sorry for the delayed response. I will let you know the results in several days.

As a temporary workaround I recommend you using the solution we proposed you above: use "mm/dd/yyyy" format in your Zoho People organization and in the Zoho People connection in Skyvia.

 

Thank you for patience.

 

Best regards,

Mariia

0
votes
Sachin Dabrein posted this 04 April 2019

Any Update?

Thanks,

Sachin

0
votes
Sachin Dabrein posted this 26 March 2019

Thanks waiting for further update.

Thanks,

Sachin Dabre

0
votes
Mariia Zaharova posted this 26 March 2019

We are investigating the issue. I will post here the results as soon as possible.

 

Best regards,

Mariia

0
votes
Sachin Dabrein posted this 25 March 2019

I did exactly the same still its giving me an error.

Please suggest for the further step.

 

Thanks,

Sachin

0
votes
Mariia Zaharova posted this 20 March 2019

Hi Sachin!

 

DateTime Format must be the same as it is specified in your Zoho People company settings. For example:

Zoho People connection in Skyvia:

Zoho People company settings:

 

 

Best regards,

Mariia

0
votes
Sachin Dabrein posted this 19 March 2019

I am getting the same data. issue is still not resolved. 

i have entered the date format as "dd/mm/yyyy". is this the right way of writing? 

else please suggest how it is working. 

 

Thanks & Regards, 

Sachin 

0
votes
Sachin Dabrein posted this 19 March 2019

Cool. 

Let me check it. 

Thanks, 

Sachin 

0
votes
Mariia Zaharova posted this 19 March 2019

Hi Sachin!

 

We have added new connection parameter to the Zoho People connection: DateTime Format. You can specify here datetime format according to the used one in your Zoho People company settings.

 

Best regards,

Mariia

0
votes
Mariia Zaharova posted this 13 March 2019

Sorry for the delayed response.

 

We have investigated the issue with reading dates from Zoho People. The issue is related to the Date Format settings. Skyvia accepts only InvariantCulture format (mm/dd/yyyy) at the moment. In your case we receive values like this one "18/01/2019" (dd/mm/yyyy). In order to resolve the issue please change Date Format in Zoho People company settings:

https://people.zoho.com/devtest/zp#admin/organization/companysettings

 

We will continue working on this behaviour and implementing fix for this case and inform you  about the results as soon as any are available.

 

Thank you for your patience.

 

Best regards,

Mariia

0
votes
Sachin Dabrein posted this 11 March 2019

any update on this?

 

0
votes
Sachin Dabrein posted this 04 March 2019

Hi Mariia, 

 

What is the progress? 

Can you please work on this case on priority. this case is open since last few weeks. 

 

Thanks, 

Sachin

Show More Posts
Close