Error restoring to HubSpot: "The value is too large to fit in the column data area of the buffer"

  • 13Views
  • Last Post 2 weeks ago
0
votes
Paul Kirkaas posted this 2 weeks ago

I am trying to restore a backup from our production hubspot account to our development/test account. I previously reported a problem - which turned out to be because the several hundred custom properties in our production account didn't exist in our newly created dev account.

So I wrote a program to use the hubspot api to get all the property definitions from our Prod account & create them in our dev account, WITH ALL PROPERTY THE DEFINITIONS - like, type, name, options, etc . That worked.

Then I tried to restore the entire production snapshot to dev, but got the error that "blogs can not be inserted". 

So then I tried to restore just the contacts & companies. Some of them were restored/inserted into our dev account, but we got 10096 successful inserts, 3040 insertion errors, with a single error message "The value is too large to fit in the comumn data area of the buffer"

There were about 600 compnay insertion errors & 2300 contact insertion errors, so it wasn't just a single field/property.

Any idea how to find out what properties are erroring? And why? The fields/properties should be the same in both accounts.

 

0
votes
Dmitriy Muzurov posted this 2 weeks ago

Hello Paul,

Thank you for submitting a ticket with us.

This error message can be fixed but for that we need to know the field that stores data longer than the length of this field.

We are not able to find that out from our side since that's your data. And log does not keep this either.

The only variant for you is to create a backup connection to your latest successful snapshot, then execute queries against it in Skyvia Query. Here is the example of query:

SELECT MAX(Length("Last Name")) FROM Contacts

This query must be executed for each field from Contacts and Companies objects that has data type listed as 28 and 13. These are our internal DBTypes. We prepared several screenshots with metadata from both your objects and sent to you via email.

There is a column 'dataType' that stores numeric data types on the screenshots. Please check each field with text (28) and enums (13) data type with the above pasted query. You will probably find out fields that have length more than it is specified in the metadata on the screenshots.

We are looking forward to hearing from you.

 

Close