Error when replicating Google Analytics

  • 66Views
  • Last Post 25 March 2021
  • Topic Is Solved
0
votes
Tomas Chejanovich posted this 25 March 2021

I've created a connection with Google Anlytics and a package to replicate GA into Redshift. 

When I run the package it immediately fails with this error: 

Unable to use "Segment" field without "Segment" field in where condition.

Please help.

 

0
votes
Sabina Bashuk posted this 25 March 2021

Hello Tomas. In Google Analytics connector there is only one table - CompleteAnalytics. It has about 360 fields, which are divided in Metrics and Dimensions. Not all Metrics and Dimensions are compatible, that's why an error occurs if you just choose the whole table.

To avoid it, you need to map the columns that are compatible.   Also, because of Google Analytics API limitations, Skyvia can query a limited number of metrics and dimensions in a single request: up to 7 dimensions and up to 10 metrics. Thus, you can select only a limited number of metrics and dimensions in your integration package tasks or queries.

Please check Google Analytics documentation for more details.

Close