First synchronization does not copy records from Salesforce Source to MySQL Target

  • 123Views
  • Last Post 29 June 2017
  • Topic Is Solved
0
votes
Sharon Cooper posted this 27 June 2017

 

We have a successful connection after resolving initial error messages. However, when the synchronization was run for the first time, records were copied from the Target (MySQL table) to the Source (Salesforce Contact object) but nothing was copied from the Source to Target.

We want the reverse: the Salesforce Source to populate the MySQL Target on the first run using the field mapping. From that point forward, changes will be made on either side.  We tried deleting all records in the Target table and running the synch but no records were copied from the Source into the Target table. Could we be missing a MySQL permission? We did not see an error message.

 

Also note that after the first synchronization a table on the Target MySQL database was created with name ...tracking_store but it is empty. 

Order By: Standard | Newest | Votes
0
votes
Mariia Zaharova posted this 29 June 2017

The main requirement for synchronizing database data is that the primary key columns of the database tables must be autogenerated.

When synchronization is performed for the first time, it does not check whether the records in sources are identical and simply copies data from one side to another and vice versa, and "maps" the original records to their copies in another source. 

When performing synchronization repeatedly, Skyvia synchronizes only data that was changed since the previous synchronization. It uses the fields storing information about when a record was created and modified in cloud applications and creates special tracking tables and triggers in relational databases for data modification tracking.

Please refer to: 

https://skyvia.com/resources/docs/index.html?synchronization_overview.htm

https://skyvia.com/resources/docs/index.html?synchronizing_product_data.htm

 

After you have checked that your primary key is autogenerated in the database table and cleared the data in this table, please open your package, click Edit and reset the LastSyncTime/InitTrackingObjects values in the Parameters section. Save the changes and run the package again.

Please also take a look at https://support.skyvia.com/thread/records-not-updating/?order=all#comment-88a09d12-4419-4ac3-a8b6-a79100bb57d3

 

Please tell us if this information helps.

0
votes
Sharon Cooper posted this 29 June 2017

We now have the synch working! If we encounter any new problems, I will let you know.

Close