How to opt out of Bulk API in a scheduled import from Amazon S3

  • 49Views
  • Last Post 04 November 2019
  • Topic Is Solved
0
votes
Tanushree Singh posted this 31 October 2019

Hi,

We are automating an Import from Amazon S3 and getting an error because of the Apex CPU time out. I don't see an option to opt out of Bulk API in a scheduled task.

 

Could you me please suggest me how we can get rid of the problem?

 

Thanks,

Tanushree

Order By: Standard | Newest | Votes
0
votes
Mariia Zaharova posted this 01 November 2019

Hi Tanushree!

 

By default, Skyvia uses Salesforce SOAP API to query data from Salesforce and Bulk API to load data to Salesforce. If Bulk API is not available for your account or you don't want to use it, you can disable Bulk API use in the Advanced connection parameters:

 

Feel free to ask any further questions.

 

Best regards,

Mariia

0
votes
Tanushree Singh posted this 01 November 2019

I didn’t find the ‘Advanced Parameters’  in scheduled jobs. Is it at a different location than for manual runs?

 

0
votes
Mariia Zaharova posted this 01 November 2019

These parameters are available for the Salesforce connection. You should open your Salesforce connection, click Edit and go to the Advanced parameters.

Please refer to http://skyvia.com/resources/docs/index.html?salesforce_connections.htm

 

Feel free to ask any further questions.

 

Best regards,

Mariia

0
votes
Tanushree Singh posted this 01 November 2019

It's not there for Amazon S3. PFB the screesnshot

1
votes
Mariia Zaharova posted this 04 November 2019

Hi Tanushree!

 

The ApexCPU issue you are getting occurs on the Salesforce side. As we have already mentioned, by default, Skyvia uses Salesforce SOAP API to query data from Salesforce and Bulk API to load data to Salesforce. You do not need to make any changes to the S3 connection, but you should look at your Salesforce connection and its Advanced parameters if you want to disable Bulk API.

 

Best regards,

Mariia

  • Supported by
  • Tanushree Singh
Close