Hubspot Backup reporting hapikey error

  • 16Views
  • Last Post 1 weeks ago
0
votes
Tony Hill posted this 2 weeks ago

I've been trialling the backup to backup our Hubspot data.

I am the Hubspot super admin and we have 1 admin and 4 users.  The API key is mine.

Attached is the typical error we get. Says the API key doesn't have the proper permissions.

Any help?

Attached Files

Order By: Standard | Newest | Votes
0
votes
Dmitriy Muzurov posted this 2 weeks ago

Hello Tony,

Thank you for contacting our Skyvia Team.

Make sure that you are using the API key not to your developer portal.

That one does not have access to any of the Marketing/CRM scopes. 

You’ll need to use the API key from your production Marketing/CRM portal.

Marketing Basic, Professional, and Enterprise customers and portals with a CRM can access the HubSpot API. Please check this article.

 

Should you have any questions, do not hesitate to contact us back.

0
votes
Tony Hill posted this 2 weeks ago

Hi Dmitriy, thanks for reply

The API key is mine, as super admin.  We haven't setup a developer key.  I set the key as per the article you mentioned.

0
votes
Dmitriy Muzurov posted this 1 weeks ago

Dear Tony,

Thank you for getting back to us.

The issue is related to insufficient permissions.

If you are sure that all necessary persmissions were granted to this key, we would recommend contacting HubSpot and asking to check whether the key is correct.

Should you have any questions, do not hesitate to contact us back.

Close