HubSpot target lookup for Contacts' "Id" field hangs

  • 18Views
  • Last Post 5 weeks ago
0
votes
cioadmin posted this 01 September 2022

We have an automation which, every night, attempts to query our SQL database for customer activity from that day and synchronize it with their related Contact objects in HubSpot.

We had a lot of success just inserting new fields, but we want to synchronize customer data (such as their Active/Inactive status) from our SQL database with their HubSpot Contact, so I am using the Upsert function, with the SQL query as the source and Hubspot as the target. For each customer with activity that day, I am performing a target lookup in Hubspot that matches a mapped-over field that we use called CustomerID provided from SQL. However, since moving over to the Upsert function, our automation was hanging for over 2 days with 0 progress, so I killed it this morning. I understand that the Target Lookup mapping function would be a little slower, but should it be "50 hours without progress" slow? Or is there something broken? The run ID for this automation is 104417530.

Attached Files

0
votes
Yevheniia Bilotserkovska posted this 5 weeks ago

Hello.

Thank you for contacting us.

As we see in your Package ID 178901 currently you have got some successful records and an error 'No record found for the specified lookup condition'.

To use the Lookup mapping, you need to have a column (or a set of columns) that uniquely identifies a record, other than the primary key or Lookup Column.

Please try to select another field in Lookup Key column.

If error returns please check whether the proper record for lookup condition exists.

Could you please check and let us know the result.

If you need any additional information from our side feel free to contact us.

Best regards,

Yevheniia Bilotserkovska.

 

Close