Import from Sugar to Salesforce

  • 25Views
  • Last Post 10 May 2019
0
votes
Devang MISTRY posted this 06 May 2019

Hi,

I am trying to migrate couple of accounts from SugarCRM to Salesforce as testing.

 

For some reason its failing, please see below.

I have a conditional filter added as shown in screenshot below for testing, I wanted to only migrate an account named ‘Zurich’ in my sugar crm to salesforce for testing. Not sure if the conditional portion is the reason for the failing of the migration.

Can you please advice what needs to be corrected here.

Order By: Standard | Newest | Votes
1
votes
Dmitriy Muzurov posted this 07 May 2019

Hello,

Thank you for contacting our Skyvia Team.

The error about conditional operator refers to the character "?": https://docs.microsoft.com/en-us/sql/integration-services/expressions/conditional-ssis-expression?view=sql-server-2017

There are two fields in your package that are mapped with the expression:

ISNULL([billing_address_street])?"Some Street":[billing_address_street]

There is a remark in the official documentation that both expression1 and expression2 must be a string data type: DT_STR or DT_WSTR.

Please add a datatype to expression2 to cast explicitly:

ISNULL([billing_address_street])?"Some Street": (DT_WSTR,255)[billing_address_street]

Let us know if it worked.

  • Supported by
  • Devang MISTRY
0
votes
Devang MISTRY posted this 07 May 2019

Thanks Dmitriy, that allows me to now at least run the query. However I am seeing 1 error row, see below screenshot of CSV. I am getting Account error and the csv downloads with the same name.

 

I am seeing all field values getting pulled over from Sugar except Name, I have Name from sugar mapped to Name in Salesforce, see below.

Please let me know what's wrong here, thanks. 

1
votes
Dmitriy Muzurov posted this 08 May 2019

Hi,

Thank you for reply.

The error messages "Complete this field" and "Please select country value" look like custom-made.

Please check if any validation rules are set up for the destination object:

1) Log in your Salesforce account 

2) Go to Your Login name -> Setup

3) On the left pane find App Setup section -> Customize -> Account -> Validation Rules

We are looking forward to hearing from you.

  • Supported by
  • Devang MISTRY
0
votes
Devang MISTRY posted this 08 May 2019

Hi,

 

Upon clicked on account name, I see below only. 

Thoughts?

0
votes
Simon Bubnov posted this 10 May 2019

Are you a Salesforce Administrator? If not, ask your Salesforce admin to give you the required permissions.

0
votes
Devang MISTRY posted this 10 May 2019

Thanks Simon for your response. Nope, the account we are using does not have admin priviledges, that said if we get admin proviledges for the account we use, will the validation rule disappear? Is it possible to discuss this over a call? Unfortunately we have to wait currenlty for over 2 days to get feedback, I also emailed skyvia support about a week ago and getting no response at all.

0
votes
Simon Bubnov posted this 10 May 2019

Admin privileges allow you to manage validation rules and disable validation rules.

Unfortunately we have to wait currenlty for over 2 days to get feedback

We are sorry for making you waiting. Yesterday was a state holiday in our country, and it wasn't a business day.

I also emailed skyvia support about a week ago and getting no response at all.

We have one ticket from you - #281718. Your last email was one week ago on May 3. And Mariia replied you an hour and a half after your email. Please check your spam filter. However, you received our previous replies earlier, so it's unlikely that the last reply could go to spam. Probably you just haven't noticed it.

Close