Incorrect string value

  • 104Views
  • Last Post 10 November 2020
0
votes
NLC Ventures posted this 21 September 2020

Hello,

Run 44245467.

We have a problem that records can't be replicated because of "incorrect string value".

We have changed the charset to utf8mb4 in all of our tables, but it still doesn't work.

We couldn't find the solution on the web, so perhaps you could guide us how to solve it.

Thanks a lot,

Danyl

Order By: Standard | Newest | Votes
0
votes
Dmitriy Muzurov posted this 22 September 2020

Hi Danyl,

Thank you for submitting a ticket with us.

There is another error message from our side for that run: "the module name given seems to be invalid"

The package does not have successful runs. We would recommend dropping tables in the target, clearing metadata cache of your Zoho CRM connection in the connection details in Skyvia and creating a new replication package.

Let us know if you face the same issue with new package.

We are looking forward to hearing from you, should you have any questions.

0
votes
NLC Ventures posted this 28 September 2020

Hi Dmitriy,

We've done the things that you recommended and it worked fine for once. But afterwards, with recurring updates, it resulted in the same error as before "the module name given seems to be invalid" + incorrect string value error for 30% of the data.

Let us know if there anything we can do to fix this.

Danyl

0
votes
Dmitriy Muzurov posted this 28 September 2020

Dear Danyl,

Thank you for getting back to us.

We raised a ticket with our developers to check the issue.

Once there are any details, we will let you know.

0
votes
NLC Ventures posted this 12 October 2020

Hi,

 

Any updates?

0
votes
Dmitriy Muzurov posted this 13 October 2020

Hello,

Thank you for getting back to us.

The issue has been fixed and the fix will be applied with new release.

We will let you know once it is released.

0
votes
NLC Ventures posted this 20 October 2020

Hi,

Do you have an idea when the new release going to happen? at least approx. date?

0
votes
Dmitriy Muzurov posted this 20 October 2020

Hi,

We expect the new release to be issued within 2-3 weeks.

Should you have any questions, do not hesitate to contact us back.

0
votes
Dmitriy Muzurov posted this 06 November 2020

Hi,

A new Skyvia version has been released and your issue should be fixed now. Please clear Metadata Cache.

We are looking forward to hearing from you, should you have any questions.

0
votes
NLC Ventures posted this 09 November 2020

Hi, the package runs without the "the module name given seems to be invalid" error, but there is still an initial problem present, which is an incorrect string value. We ensured that DB settings are set up to utf8mb4, but the problem is still there and around 30% of the data wasn't replicated.

 

Run #46578767

Is there any advice that could help us to solve the issue?

Looking forward to your response,

 

Thanks,

Danyl

0
votes
Dmitriy Muzurov posted this 10 November 2020

Hi Danyl,

Thank you for reply.

In Advanced Settings of your MySQL connection in Skyvia account, you can select the Unicode check box to use Unicode encoding for the connection.

Please select it, run the package and let us know if the issue still persists.

We are looking forward to hearing from you.

Close