Intermittent Partially Failed Imports

  • 49Views
  • Last Post 29 September 2021
  • Topic Is Solved
0
votes
Jay Ong posted this 23 September 2021

HI Skyvia Support,

A number of my imports have been partially failing over the past 2 weeks. The error message is:

A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: TCP Provider, error: 0 - An existing connection was forcibly closed by the remote host.)

Usually the first 2 records do not get imported, but the rest of the records does. Manually re-running the import package (configured with UPSERT) resolves the issue. Can you please investigate and advise why I am receiving these error? Nothing has changed on my end for months.

Regards & thanks
Jay

 

Order By: Standard | Newest | Votes
1
votes
Jay Ong posted this 29 September 2021

I have increased the Connection Timeout. I'll monitor over the next week. Thanks for the advice Nataliia.

  • Supported by
  • Nataliia Nikulina
0
votes
Nataliia Nikulina posted this 24 September 2021

Hello Jay,

Thank you for contacting Skyvia Support team.

The error comes from the SQL Server side and may be related to some server load, its instability, etc.    

You can open your SQL Server connection in Skyvia and increase timeout parameters - Command Timeout and Connection Timeout parameters (in the Advanced settings) to prevent such an error in the future.    

See more information in the link below:  

https://docs.skyvia.com/connectors/databases/mysql_connections.html    

 

Please update us about the results.  

 

Best regards,

Nataliia,

Customer Support Engineer 

Close