Mapping NetSuite Custom Fields

  • 59Views
  • Last Post 20 March 2019
0
votes
David Weninger posted this 11 March 2019

How do I map custom fields from NetSuite to SQL? For example we have many custom fields on the NetSuite Customer. When I map the NetSuite Customer to SQL, I only see NetSuite fields.

Order By: Standard | Newest | Votes
0
votes
Mariia Zaharova posted this 11 March 2019

Hi David!

Please open your NetSuite connection and select the 'Use Custom Tables' and 'Use Custom Fields' check boxes. More information is available here:

https://skyvia.com/resources/docs/index.html?netsuite_connections.htm

 

Please tell me if this helps.

 

Best regards,

Mariia

0
votes
David Weninger posted this 11 March 2019

I have both options checked. I am not seeing the custom fields when I run the sync.

0
votes
Mariia Zaharova posted this 13 March 2019

Hi David!

We checked metadata of your NetSuite connection and there are a lot of custom fields in the Customer table.

Please open your package, click Edit for Customer task and then click the Refresh button. Whether custom fields are available and checked? If not, please specify whether all custom fields are not available in the Task Editor or only some of them.

 

Looking forward to your reply.

0
votes
David Weninger posted this 17 March 2019

I clicked Refresh on the Customer object in my NetSuite connection. I still do not see any custom fields. Can we have a WebEx tomorrow (Monday)? I need to get this working.

0
votes
Mariia Zaharova posted this 18 March 2019

Hi David!

 

Please also try these steps:

 - open your NetSuite connection and click the 'clear' for "Metadata Cache" parameter;

- open your package and edit the Task; if fields are still not available, try clicking Refresh button again.

 

Looking forward to your reply.

0
votes
David Weninger posted this 18 March 2019

Clear was not an option for Metadata Cache. I changed it to Disabled and Refreshed the customer table. Still not seeing custom fields.

0
votes
Mariia Zaharova posted this 19 March 2019

Please specify the names of the fields which you are expecting to see in your package.

 

Please note the following limitations: Skyvia does not support NetSuite fields, storing array data, and does not support custom NetSuite fields having double quotation marks in their name.

0
votes
David Weninger posted this 19 March 2019

Here are some examples:

0
votes
David Weninger posted this 19 March 2019

Can I get a reply on this today? We are two weeks from go-live and I need to determine if Skyvia can do what we need.

0
votes
Simon Bubnov posted this 20 March 2019

The reason of the issue can be the account configuration. Please perform the following actions:

1. Go to NetSuite site and click Setup > Users/Roles > Manage Roles. Then find the user that you use when you connect to NetSuite in Skyvia. Remember the value in the Role column for your user.

2. You need to edit this role and grant various customization-related permissions. In NetSuite go to Setup > Users/Roles > Manage Roles. Find the role that we got in the step 1. and click edit for it.

3. Edit the following: Permissions > Setup. Grant the following permissions with the "Full" access Level:

Custom Body Fields

Custom Column Fields

Custom Entity Fields

Custom Event Fields

Custom Fields

Custom Item Fields

Custom Item Number Fields

Custom Lists

Custom Record Types

Custom Transaction Fields

Other Custom Fields

http://prntscr.com/n0fwoo

4. Save the role.

 

Now if you connect to NetSuite with the user with this role and select true for Use Custom Fields and Use Custom Tables in Skyvia NetSuite connection, you will have access to custom fields.

 

Please note that custom fields may appear not right after these actions, but after some more time, for example, an hour. When we tested this scenario, custom fields were available immediately after setting up the required permissions.

 

Close