Marketing Cloud Business Unit Access Issue for Data Extensions

  • 568Views
  • Last Post 05 January 2023
  • Topic Is Solved
Craig Gjerdingen posted this 06 August 2020

I'm getting an Error for my Target: Unable to retrieve Data Extension using CustomerKey

I can see the Data Exension and do the mapping. And Additionally I can run data into the top level Business Unit (BU) no problem.

But once I add a "Partner IDs" Business Unit ID to my Skyvia Marketing Cloud Connection to Target a sub BU the insert doesn't work.

I have tried in the top level Business Unit (BU) and the inserts work great.

I have remapped and made sure all the settings are the same at the top and in lower level, sub BUs. 

ErrorDescription: An error occurred while processing the request: Unable to retrieve Data Extension using CustomerKey;

The attachment, shows the Business Unit hierarchy. 


Attached Files

Order By: Standard | Newest | Votes
Craig Gjerdingen posted this 11 August 2020

I have found that if I change the default business unit in Salesforce Marketing Cloud for the account I'm using in Skyvia. Then the connection to the data extensions work as expected.

It appears that if the Default Business Unit for the user in Marketing Cloud is set to something other than the one used in the "Partner Ids" Skyvia connector field. Skyvia can see them in the integration designer, but can't access it for writing.
  Once I changed the default business unit for the user in Marketing Cloud, it works.    This isn't super easy to find in Saleforce Marketing Cloud UI; Login->Email->Admin->My Users, select the users checkbox, then Manage Business Units, then Set the users Default Business Unit. 

Once this is  done, you also no longer need to supply Skyvia with the "Partner Ids"

Hope this helps someone out there!

  • Supported by
  • Serhii Muzyka
Mariia Zaharova posted this 07 August 2020

Hello Craig,


We are processing your request and will answer you by email as soon as possible.


Best regards,


Dmitriy Muzurov posted this 12 August 2020

Dear Craig,

Thank you for getting back to us.

We would be able to get more details, if run the package with extended logging.

You can provide us with the ID of the package, so that we test it on our side.

Mana Olandj posted this 04 January 2023


I have the same issue / error message.

When i update the Default Business unit the mapping does work on the data extension in the child business unit. But then i hace. ann error on the data extension on the parent Business Unit. 

However i need the mapping to work on data extension on both Business unit (parent BU and child BU). 



Serhii Muzyka posted this 05 January 2023


We are really sorry for the inconvenience.


We see that you have already been communicating with our team by email. 


Let's keep our communication regarding your case there.


Best regards,