Netsuite BigQuery Replication failure

  • 189Views
  • Last Post 27 May 2022
Elie Ben Ayoun posted this 26 May 2022

Hello, I am trying to test sky via to see if it will fit our company requirements. 

I created a package for replication with for origin NetSuite (the connection was tested and worked) and for destination BigQuery (The connection was also tested and worked also )

When I run the package I can see that the program is taking the correct number of records from Netsuite but all of these records failed and when I click on the failed import (or failed logs) to see why it failed I don't see any details

I read on one of your support questions that the checkbox Bulk imports should be unchecked to access the error message from BigQuery, I did it and nothing change (still 100% errors and no details) 


I tested with different Netsuite records selected and the result was always the same 


Can you please explain to me how to avoid this issue? 



Mariia Zaharova posted this 27 May 2022

 Hello Elle,


Thank you for contacting us.


The Use Bulk Import option works only for Import packages, not Replication.

We have checked our logs and see the following error:

Cannot read and write in different locations: source: US, destination: us-central1


This error occurs while reading the data from a temporary CSV file in the bucket and sending it to the BigQuery table.

Make sure your Cloud Storage Bucket and Dataset use the same location.


Looking forward to your reply.


Best regards,