Postgresql connection error: The server hello message uses a protocol that was not recognized.

  • 227Views
  • Last Post 2 weeks ago
0
votes
Stephen Thompson posted this 12 May 2021

We are facing same issue.

 

Postgresql connection error: The server hello message uses a protocol that was not recognized. (skyvia.com)

 

And we have no resolution, also not getting any resolution from already logged ticket's answers.

Order By: Standard | Newest | Votes
0
votes
Sabina Bashuk posted this 13 May 2021

Hello Stephen,

What version of PostgreSQL are you using? What settings?

Have you tried to enable TLS 1.2?

Please provide us with the link to the connection here or to support@skyvia.com, so that we could check

0
votes
Alfonso Areiza Guerra posted this 13 August 2021

I got the same error. I'm using PostgreSQL 13.3 and tried to make connection with SSL TSL Protocol 1.0, 1.1, e 1.2 but the result is the same. The server hello message uses a protocol that was not recognized.

0
votes
Nataliia Nikulina posted this 22 October 2021

Hello Alfonso,

 

We are sorry for the late reply.

 

Our team is in the progress of investigating this error. 

I will revert to you as soon as I have the result from them.

Feel free to contact us in case of any questions or issues.

 

Best regards,

Nataliia,

Customer Support Engineer 

0
votes
Kristen Bennett posted this 5 weeks ago

Have you found a solution for this? We are experiencing the same problem. After Postgres upgrade to version 13.4 We are getting The server hello message uses a protocol that was not recognized. for all TLS configurations (ssl required, TLS 1.0 1.1 1.2). I have confirmed that Postgres server accepts 1.2 and 1.3 (I've tested this with openssl openssl s_client -connect <addres>:5432 -starttls postgres -tls1_2 .

 

0
votes
Mariia Zaharova posted this 5 weeks ago

Hello,

 

This issue is a known problem, our team has to perform a serious intervention to the connection provider to fix it.

These actions may have an impact on other users of our PostgreSQL connector, thus it has to be done smoothly.

We plan to release the fix for this issue with the next Skyvia update, I will inform you additionally about the release.   

 

Thank you for understanding.   

 

Best regards, 

Mariia

0
votes
Kristen Bennett posted this 5 weeks ago

Hello, can you provide me with an information about the fix release date?

0
votes
Mariia Zaharova posted this 4 weeks ago

Hello,

 

Presumably, the next Skyvia update will be in 1-2 weeks.

 

Best regards, 

Mariia

0
votes
Kristen Bennett posted this 3 weeks ago

Is there an update regarding the fix release date?

0
votes
Mariia Zaharova posted this 3 weeks ago

Hello,

 

We would like to inform you that the issue has been fixed.

Feel free to check and revert back to us in case of any further questions.

 

Best regards,

Mariia

0
votes
Kristen Bennett posted this 3 weeks ago

Testing the connection is successful but packeges are having the same problem.

1
votes
Mariia Zaharova posted this 2 weeks ago

 Hello Kristen,

 

Please select the "Use new runtime" checkbox in your package:

 

Let us know the results.

 

Best regards,

Mariia

 

  • Supported by
  • Kristen Bennett
0
votes
Kristen Bennett posted this 2 weeks ago

This has solved our issue.

0
votes
Mariia Zaharova posted this 2 weeks ago

Hello Kristen,

 

Glad to see that the issue is resolved.

 

Feel free to contact us in case of any further questions.

 

Best regards,

Mariia

Close