Postgresql connection error: The server hello message uses a protocol that was not recognized.

  • 330Views
  • Last Post 13 May 2021
0
votes
Odette Melvin posted this 04 February 2021

When trying to add a connection to a Postgresql database, I get the following following error: The server hello message uses a protocol that was not recognized.

I have checked that I can connect to the database through other clients.

The database is hosted by Heroku. It is Postgres version 13.1. It requires SSL. In advanced settings I put Protocol=SSL, SSL Mode=Require, with SSL Certs / Keys empty.

Do you know how I can fix this? 

What TLS protocol is Skyvia using?

Thanks!

Order By: Standard | Newest | Votes
0
votes
Dmitriy Muzurov posted this 11 February 2021

Hi Odette,

Thank you for submitting a ticket with us.

Please make sure TLS 1.2 is enabled. Should that not work, enable 1.1, this is supported for backward compatibility.

We are looking forward to hearing from you, should you have any questions.

1
votes
Stephen Thompson posted this 12 May 2021

Hi We are facing same issue.

 

Any resolution for it?

  • Supported by
  • Nathan Palmer
0
votes
Sabina Bashuk posted this 13 May 2021

Hello Stephen,

What version of PostgreSQL are you using? What settings?

Have you tried to enable TLS 1.2?

Please provide us with the link to the connection here or to support@skyvia.com, so that we could check

Close