Problem on User upload: Target object 'User' does not have column 'UserPermissionsMobileUser'.

  • 15Views
  • Last Post 15 April 2020
0
votes
Alexander Strakhov posted this 02 April 2020

Dear support,

 

I'm getting an error Target object 'User' does not have column 'UserPermissionsMobileUser'.

The field is required in tqarget definition and set = false by the constant.

The package was working one weeke ago.

Please support here.

Package link: https://app.skyvia.com/#/32120/packages/89487/debug

 

 

Order By: Standard | Newest | Votes
0
votes
Mariia Zaharova posted this 03 April 2020

Hello Alexander, 

 

 

We have investigated the issue with this field. This field 'UserPermissionsMobileUser' most likely appears as a result of Permissions settings for the user or activation of any features on the Salesforce side. We recommend you to contact Salesforce support regarding whether this field exists in your instance or not.

In Skyvia: try disabling Metadata Cache and/or recreating Salesforce connection. 

 

Best regards,

Mariia

0
votes
Alexander Strakhov posted this 14 April 2020

This field and others are is not available for APEX.

UserPreferencesHideS1BrowserUI

https://salesforce.stackexchange.com/questions/68784/list-of-user-fields-not-available-in-apex

However is marked as required in teh package.

How can I excludee the feild from the package?

0
votes
Mariia Zaharova posted this 15 April 2020

Hello Alexander, 

 

Thank you for your reply.

As we have mentioned above, please try disabling Metadata Cache in your Salesforce connection or recreating the Salesforce connection (the most preferred option). 

 

Best regards,

Mariia

Close