Replicating from Salesforce to MS Azure MS SQL Database

  • 28Views
  • Last Post 22 April 2020
0
votes
Charles Cabato posted this 15 April 2020

I am trying to replicate Salesforce data to a Microsoft Azure SQL Database. I have set up connection and target correctly as both when tested connection succeeds. However when I run the package, I keep getting an error "An item with the same key has alreaady been added". I am replicating to an empty SQL Database and have checked the "Drop Table, Create Tables" options.

Order By: Standard | Newest | Votes
0
votes
Mariia Zaharova posted this 15 April 2020

Hello Charles,

 

Thank you for contacting our Skyvia Team!

 

We created a request for our developers to check this case.

Please specify whether you are using the "Use new runtime" option. Also, can we run your package in the test mode (your data will not be accessed, the package will be performed with the extended logging)?

 

Looking forward to your reply.

 

Best regards,

Mariia

0
votes
Charles Cabato posted this 15 April 2020

"Use new runtime" is checked. Yes, you may run the package to extract logs.

0
votes
Mariia Zaharova posted this 16 April 2020

Hello Charles,

 

Thank you for your reply.

We have fixed the issue. The fix will be included in the nearest Skyvia update.

We will post here when it is done.

 

Best regards,

Mariia

0
votes
Charles Cabato posted this 20 April 2020

Hi,

 

Any news when the update will be deployed?

0
votes
Mariia Zaharova posted this 21 April 2020

Hello Charles,

 

Presumably, Skyvia will be updated this week.

 

Best regards,

Mariia

0
votes
Mariia Zaharova posted this 22 April 2020

Hello Charles,

 

We updated Skyvia. Please run your package and let us know the results.

 

Best regards,

Mariia

Close