S3 connection errors

  • 51Views
  • Last Post 01 July 2021
0
votes
Dan Cook posted this 25 June 2021

I haven't succeeded at creating an S3 connection. I have a valid access key and secret key. I am leaving the security token field blank because this is not meant to be a temporary (session-based) connection.

I have the region set as the same region as the relevant AWS account, although technically S3 buckets are global and not fixed to a particular region/AZ.

I have used the bucket name, the bucket name with s3:// prefix, the ARN of the bucket. None have worked.

The error which I typically get is "Error accessing AWS. Error: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel." If I prefix s3://, the error is "Error accessing AWS. Error: The remote name could not be resolved: 's3'". If I use the bucket's ARN, the error is "Invalid URI: Invalid port specified."

I have also generated 3-part temporary credentials (AWS_ACCESS_KEY_ID, AWS_SECRET_ACCESS_KEY, AWS_SESSION_TOKEN) and these haven't worked either.

0
votes
Nataliia Nikulina posted this 01 July 2021

Hello Dan,    

 

Thank you for contacting Skyvia Support team.    

 

It looks like you don’t have access to Amazon S3 - this usually happens because of the security settings.    

 

We recommend that you whitelist the IPs 40.118.246.204 AND 13.86.253.112.    

 

Let us know if this works for you.  

 

Kind regards, 

Nataliia

Close