Salesforce account update not showing all fields

  • 288Views
  • Last Post 01 August 2017
Andrew posted this 27 July 2017

I'm looking to update an account field "MP Credits Used" This field is not showing up when I look for it on Skyvia (there are a few others that don't too).  The CSV I'm using has SF ID's to find the correct account.  Just not sure why Skyvia isn't showing all of the fields my account object has.

Order By: Standard | Newest | Votes
Mariia Zaharova posted this 28 July 2017

By default, Skyvia caches metadata of available objects for cloud sources. Please refer to:

Please perform the following steps:

  • open your Salesforce connection and click the 'clear' link for "Metadata Cache" parameter;
  • open your package and edit the Task; if fields are still not available, try clicking Refresh button (also, make sure you are not filtering columns at this step - if some buttons, such as 'mapped', 'unmapped', 'valid' or 'required' in the Task, are selected, not all fields will be shown).

The 'clear' link is available in the Parameters pane when opening the connection to see its details:


Please tell us if this helps.

Andrew posted this 28 July 2017


Thanks for the quick response here. Unfortunately still no dice...There are no new fields showing up (since the last run).  These fields were actually all in place when I started using skyvia.




Mariia Zaharova posted this 01 August 2017

Please try creating new Salesforce connection and check if these fields are available in the Task Editor with the new connection.

If fields are still not available, please describe how these fields were created in Salesforce (e.g. send us screenshots, in particular, for the Step 3 "Establish field-level security").