Salesforce UPSERT

  • 98Views
  • Last Post 26 May 2017
  • Topic Is Solved
0
votes
paul Shuster posted this 24 May 2017

I am having a very frustrating time with Skyvia uploading to Salesforce.  I originally had a CSV file uploading just fine to my salesforce objects.  But I have added a few additional fields and they do not show up in Skyvia for mapping.  I even changed the external ID from one of the original fields to a new field I added, but only the original field shows up to select as the external ID.

 

Why do I not see the changed in the Salesforce table?

Order By: Standard | Newest | Votes
0
votes
Mariia Zaharova posted this 25 May 2017

Please perform the following steps:

- open your Salesforce connection and click the Clear link for "Metadata Cache" parameter;

- open your package and edit the Task; if fields are still not available, try clicking Refresh button (also, make sure you are not filtering columns at this step - if some buttons, such as 'mapped', 'unmapped', 'valid' or 'required' in the Task, are selected, not all fields will be shown).

By default, Skyvia caches metadata of available objects for cloud sources. Please refer to:

https://skyvia.com/resources/docs/index.html?salesforce_connections.htm

0
votes
paul Shuster posted this 25 May 2017

When I edit the connection to Salesforce,  I don't see a 'Clear' for the Metadata Cache - only disable in the drop-down list beside Metadata Cache.  Is the 'Parameters Pane somewhere else?

0
votes
Mariia Zaharova posted this 26 May 2017

The Clear link is available in the Parameters pane when opening the connection to see its details, but not in the Connection Editor:

Close