SkyVia agent starts and then stops immediately on Windows Server 2019 x64 (1809)

  • 76Views
  • Last Post 10 June 2022
  • Topic Is Solved
Plamen Petkov posted this 09 May 2022

I have a similar issue as many and just reposting another user's description which covers my case 100%

 Normally installing Skyvia is a breeze. Install Skyvia, create the security key file, install Skyvia as service and then start the service.

However, this time the Skyvia service won't run. After starting the service, it STOPS IMMEDIATELY.

I can start Skyvia manually without issue!

 Logging also says installing as service was correct:

Installing service Skyvia.Agents.Client...

Service Skyvia.Agents.Client has been successfully installed.

Creating EventLog source Skyvia.Agents.Client in log Application...

Committing assembly 'C:\Program Files (x86)\Skyvia Agent\Skyvia.Agent.Client.exe'.

Affected parameters are:

   logtoconsole = 

   logfile = C:\Program Files (x86)\Skyvia Agent\Skyvia.Agent.Client.InstallLog

   assemblypath = C:\Program Files (x86)\Skyvia Agent\Skyvia.Agent.Client.exe

I also saw this post:

But the two listed cases are not at play here:

Such an issue may occur in the following cases:

 agent is already installed as a service;

you are running this command in the wrong directory (the command has to be performed in the folder where the agent is installed.).

Skyvia was not present and did stop immediately after first installation

The commandline has been ran from the appropiate directory:

C:\Program Files (x86)\Skyvia Agent\Skyvia.Agent.Client.exe -i

 I had a case almost similar like this before, but that was caused by the security key not named properly (skyvia_security_agent.key.txt instead of skyvia_security_agent.key)
In this case, Skyvia couldn't start manually either.

But this case is new. 

Things we tried:

- Uninstall Skyvia service and reinstall it
- Create a new Security Agent key
- Install and Start the service under a different window user
- Start the service with an admin account attached to it
- No helpful Event logs, it just says that the service was stopped. No errors, no warnings
- Skyvia can be started manually and connects

And for clarification: Commandlines have been run from cmd prompt with "Run as administrator"

I have currently no more ideas what to try. Please advice.

Order By: Standard | Newest | Votes
Olena Romanchuk posted this 11 May 2022

Hello Plamen,

Please try the following:

Open the Start menu, search for Services, and click the top result to open the console.
Double-click Skyvia Agent service 
Click the Start button.
Use the "Start type" drop-down menu and select the Automatic option
Click the Apply button. Click the OK button.

Generally, the issue is related to local server configuration, not to Skyvia.

There is no specific recommendation on how to configure your server not to stop the service after the start.

You can try to search the solution here:

best regards,


 Technical Support Engineer

Plamen Petkov posted this 02 June 2022

Hello, I've tried everything I've read on the forum here. There's no specific server config done. It's a brand new Windows server 2019 x64. Nothing in the logs. When run as a console application the agent exe works flawlessly. Can we possibly have a session together with the support stuff and try to find a solution as this is a deal breaker for us during the PoC.




Mariia Zaharova posted this 03 June 2022

Hello Plamen,


Thank you for your reply.


Unfortunately, we do not provide phone support at the moment.

The issue is under investigation by our developers. I will post here the results as soon as possible.


Best regards,


Mariia Zaharova posted this 08 June 2022



Please download a new version of Agent 1.2.67 and install it.

Also, please open Skyvia.Agent.Client.exe.config file and the AgentKey line.


After this, please try running it as a service and let us know the results.


Best regards,


  • Supported by
  • Plamen Petkov
Plamen Petkov posted this 10 June 2022

I can confirm 1.2.67 Agent service has no problems operating as a service. Pending additional testing.