SQL Server Connection

  • 24Views
  • Last Post 03 August 2018
  • Topic Is Solved
0
votes
Steve Robinson posted this 02 August 2018

Hi, I'm getting the error below when attempting to set up a connection to SQL Server. I believe I have everything entered correctly (see attached), and port 1433 is open on the firewall.  Let me know if you see anything incorrect in my setup or have suggestions on what the issue might be.

Thanks, Steve

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.)

 

 

Attached Files

0
votes
Mariia Zaharova posted this 03 August 2018

As we can see from your screenshot, you are using the following IP: 192.168.45.136. But it is a local IP address of your network. Skyvia cannot find such IP address. First, you need to make your SQL Server available from the Internet: https://support.skyvia.com/thread/connection-to-sql-server/

When working with SQL Server connections, the main requirement is that your SQL Server database must be available through the Internet. If connecting to a computer in the local network, it is necessary to use port forwarding.

Thus, please contact you system administrator to make SQL Server accessible from Internet with port forwarding.

After this you can try using the following format for the Server parameter for connecting to SQL Server through Internet:

 

Server = tcp:IP\named instance,1433

 

where

IP - is an external IP address of the computer with SQL Server (you can find external IP by using any site which provides such functionality, for example, myexternalip.com/)

named instance - your named instance

1433 - the port, on which SQL Server is listening. 1433 is a default port. If SQL Server is listening on another port, you should change it to the corresponding one.

Close