SQL Transport Layer Error

  • 78Views
  • Last Post 28 March 2021
  • Topic Is Solved
0
votes
Technology Specialist posted this 19 March 2021

Hello Support Team!

I'm having an issue with Skyvia importing data into SQL and the issue seems to be inconsisntently happening. Today most of the automatic (Scheduled) package runs were successful however any manual run I try fails.
Some of the scheduled runs did also fail all with the following error:

A transport-level error has occurred when receiving results from the server. (provider: Session Provider, error: 19 - Physical connection is not usable)

I did follow skyvia support documentation on setting up a TCP/IP connection to SQL. I have verified those settings are correct. Have you seen this error before?
Any help or clues you can provide would be much apprecited, thank you!!

Order By: Standard | Newest | Votes
0
votes
Dmitriy Muzurov posted this 24 March 2021

Hello,

Thank you for contacting us.

It seems the issue can be related to various reasons.

 

Please try specifying Server parameter similar to what is described here.

 

We are looking forward to hearing from you, should you have any questions.

1
votes
Technology Specialist posted this 24 March 2021

Hi Dmitriy, 

Thank you for the response.
We did have port forwarding setup and has been working for months. I believe a SQL update, or an increase in traffic through that port from another application was causing a conflict with Skyvia's connection traffic to SQL Server. I can't say for sure but speculation leads me to believe SQL connections were not terminating correctly.

However,
I was able to fix the issue above by switching from direct connection to using Skyvia Agent from a different server.

  • Supported by
  • Sabina Bashuk
0
votes
Dmitriy Muzurov posted this 28 March 2021

Hi,

We are glad to know the issue is solved.

Feel free to contact us, should you have any questions.

Close