Taks are not imported

  • 376Views
  • Last Post 24 May 2019
Buymanager Migration posted this 23 May 2019


I am working on a Zoho CRM to Salesforce synchronization.

We could not synchronize Taks due to the error "Assigned To ID: id value of incorrect type: 1052444000003868166". We tried to correct it by modifying the Owner ID and Related To ID but the sync. did'nt work as well.



Please advise on how to correct this.

Order By: Standard | Newest | Votes
Mariia Zaharova posted this 23 May 2019



This error means that you are sending incorrect values to the WhoId field (SF). You are using Column mapping for this field and map it with the Zoho CRM field. Both fields store different values in Salesforce and Zoho CRM. WhoId (Salesforce) field refer to the Contact or Lead object and can store only Salesforce Contact or Lead Id values, this field cannot store Zoho CRM Id values. 

Example of values stored in the WhoId field (Task, Salesforce): http://prntscr.com/nsavo4

Example of values stored in the RELATEDTOID field (Calls, Zoho CRM): http://prntscr.com/nsawbr


You can either remove mapping for this field or use Lookup mapping if it is necessary to map it for your scenario. 

See more here: https://developer.salesforce.com/forums/?id=906F00000008wZlIAI



Example of Lookup mapping (considering Task must be related to Salesforce Account):

  • Supported by
  • Buymanager Migration
Buymanager Migration posted this 23 May 2019

Alright, so to link Tasks with Accounts, we should use Target and Source Lookup for WhatID. Correct ?And for the Who ID, it's for Contacts or Leads ?

But our Tasks are linked to both Contacts or Leads.

So how can we relate to Contact and Lead ? 


Many thanks

Buymanager Migration posted this 24 May 2019


We tried these settings for Tasks and Calls for the WhatID field and it mostly worked. We still have these 2 errors for some record :

  • No record found in object 'Accounts' for lookup by column 'ACCOUNTID' = 'XXXXX'.
  • The specified lookup by column 'Name' = 'XXXX' is ambiguous.The 'Account' object must return at most one row for the specified lookup condition.

How can we solve this ?