Time out exception running a query on google sheets add-on

  • 36Views
  • Last Post 4 weeks ago
0
votes
Raphaël Vaugan posted this 5 weeks ago

Hi,

I get a time out exception when running a query on google sheets with the skyvia add-on.

The same query works fine when I run it from app.skyvia.com

Please advise

Order By: Standard | Newest | Votes
0
votes
Mariia Zaharova posted this 5 weeks ago

Please specify the data source being used and the query you are trying to run.

Looking forward to your reply.

0
votes
Raphaël Vaugan posted this 5 weeks ago

Hello Mariia,

the datasource is Magento, and the query is named Test 20180525. Do you have access to my account?

Many thanks.

0
votes
Raphaël Vaugan posted this 5 weeks ago

This is the query:

https://app.skyvia.com/api/queries/2973/data?

0
votes
Mariia Zaharova posted this 4 weeks ago

Thank you for the details. Please also specify the version of your Magento - 1 or 2. We are looking forward to your reply.

0
votes
Raphaël Vaugan posted this 4 weeks ago

Hi There,

it's Magento 1.

0
votes
Mariia Zaharova posted this 4 weeks ago

Sorry for the delay. We are still investigating the issue you've faced. Please create Export package for this Magento table, select columns and set filter settings that are used in your query. Save and run this package several times and notify us about the results.

We are looking forward to your reply.

0
votes
Mariia Zaharova posted this 4 weeks ago

Also, tell us do you get timeout error any time you're running your query in Google Sheets Add-on? Try it now, what is the result?

0
votes
Raphaël Vaugan posted this 4 weeks ago

Hi there,

I've run the export package 4 times. It is 64 records and takes from 2 min 13 secs to 2 min 45 secs to complete.

I've also run the same query in Google Sheets Add-on. It took about the same time to run and was succesfull.

Have you increased the time out parameters? Please note there is a deliberate small number of records in the query. Would it work for a larger number?

Thanks,

0
votes
Mariia Zaharova posted this 4 weeks ago

Have you increased the time out parameters?

No, we did not make any changes. Timeout for Magento is set to 600 secs.

 

Please note there is a deliberate small number of records in the query. Would it work for a larger number?

Yes, it should. Especially, you use the filter for increment_id. In this case, one request is sent to Magento server and should not take much time to perform.

However, please note, you are using Magento 1 which is slower than Magento 2 and even one single request can take more time or fail to execute (at server side). 

As Skyvia works via Magneto API, it is limited by its API, i.e. all Magento API limitations, speed, etc., affect Skyvia.  

Close