Timeout on SQL Integration

  • 225Views
  • Last Post 23 August 2017
0
votes
Joe posted this 15 August 2017

Hi, one of my integrations with SQL keeps failing with a timeout error.  The integration is selecting from a SQL view, which does take some time to pull the data.  How do I specify the command timeout on the command itself, and not the connection?

Order By: Standard | Newest | Votes
0
votes
Mariia Zaharova posted this 15 August 2017

The Command Timeout parameter that is set for your SQL Server connection will be applied for all commands which will be performed on this connection. There is no way to set command timeout for a separate internal command. Thus, please open your SQL Server connection, click Edit and try increasing the Command Timeout parameter on the Advanced tab: https://skyvia.com/resources/docs/index.html?sqlserver_connections.htm

Best regards,

Mariia

0
votes
Joe posted this 15 August 2017

Thanks Mariia.  I have tried adjusting the command timeout parameter on the connection, but no matter what value I use my integration always times out at around 5 minutes.  The exact error is below:

Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.

0
votes
Mariia Zaharova posted this 16 August 2017

Thank you for the reply. We will investigate the issue more clearly and contact you as soon as possible.

0
votes
Mariia Zaharova posted this 23 August 2017

We have fixed the issue and updated Skyvia. The issue was related to the fact that increasing the Command Timeout parameter was not taken into account.

Please try your scenario again and notify us about the results.

Close