Unable to connect to AWS Sql Server for replication from NetSuite

  • 289Views
  • Last Post 27 October 2017
  • Topic Is Solved
0
votes
Ed Zanelli posted this 27 October 2017

I'm trying to evaluate your replication software using NetSuite as source. For the destination I just created a new AWS SQL Server instance, and set it to be publicly accessible. When I try to test the connection to SQL Server using server, username, password and database, I get an error. I am able to connect to the instance using SQL Server Management Studio using the same credentials. Here's the error message from Skyvia:

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

I have tried various combinations: with and without TCP: prefix; and, with port (1433) indicated at end (separated with : or ,).

Here's the error message with TCP: prefix:

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.)

Your help will be greatly appreciated!

Order By: Standard | Newest | Votes
1
votes
Mariia Zaharova posted this 27 October 2017

When working with SQL Server connections, the main requirement is that your SQL Server database must be available through the Internet. If connecting to database on the local computer, it is required to allow such connections in your firewall. If connecting to a computer in the local network, it is necessary to use port forwarding.
Please refer to: 
https://skyvia.com/resources/docs/index.html?sqlserver_connections.htm
https://skyvia.com/resources/docs/index.html?how_to_configure_sql_server_to.htm

Please try using the following value for the Server connection parameter:

tcp:IP\named instance,1433

where
IP - is an external IP address of your SQL Server
named instance - your named instance. Please contact to you SQL Server administrator to get this value
1433 - port, on which SQL Server is listening. 1433 is a default port. If SQL Server is listening another port, you should change it for corresponding one.


Please tell us if this information helps.

  • Supported by
  • Ed Zanelli
0
votes
Ed Zanelli posted this 27 October 2017

This suggestion did not work. You can see my login, but I prefer not to put that information here in a public place, so I have replaced a key phrase with xxx. Here are the error messages:

server=tcp:xxx.cgzybr7a7fup.us-east-2.rds.amazonaws.com\xxx

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)

server=tcp:xxx.cgzybr7a7fup.us-east-2.rds.amazonaws.com\xxx,1433

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.)

Please advise.

0
votes
Ed Zanelli posted this 27 October 2017

I remind you that I was able to connect using SQL Server Management Studio using the original credentials.

0
votes
Mariia Zaharova posted this 27 October 2017

Thank you for the reply. Please try using Server parameter in this format:

 

tcp:xxx.cgzybr7a7fup.us-east-2.rds.amazonaws.com

The database name please put to the Database field. Please also make sure you are using correct User Id and Password values.

If this doesn't help, please check the configuration of your database one more time. Please also note, Skyvia will connect to Amazon SQL Server database from IP 40.118.246.204, so you should setup your database to allow connection from this IP.

Close