Unable to create New Connection to SQl Server

  • 259Views
  • Last Post 27 October 2017
  • Topic Is Solved
0
votes
Niraj Ganani posted this 27 October 2017

Hi Team,

I have configured my SQL server properly as per the documentation you provided. I am using SQL Server 2014 Express. But while creating connection, I am getting below error message

"A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)"

Attached Files

Order By: Standard | Newest | Votes
0
votes
Mariia Zaharova posted this 27 October 2017

Please refer to this thread https://support.skyvia.com/thread/connection-to-sql-server/

Does this information help?

0
votes
Niraj Ganani posted this 27 October 2017

I have done the required changes but still it gives that error message. Kindly help, it's really urgent

0
votes
Simon Bubnov posted this 27 October 2017

As we can see from your screenshot, you are using the following IP: 192.168.1.106. But it is a local IP address of your network. Skyvia cannot find such IP address. First, you need to make your SQL Server available from the Internet. There is the following information in the topic, to which Maria sent you the link:

When working with SQL Server connections, the main requirement is that your SQL Server database must be available through the Internet.

If connecting to a computer in the local network, it is necessary to use port forwarding.

 

Please contact you system administrator to make SQL Server accessible from Internet with port forwarding.

After this you can try using the following format for the Server parameter for connecting to SQL Server through Internet:

 

Server = tcp:IP\named instance,1433

 

where

IP - is an external IP address of the computer with SQL Server

named instance - your named instance

1433 - the port, on which SQL Server is listening. 1433 is a default port. If SQL Server is listening on another port, you should change it to the corresponding one.

0
votes
Niraj Ganani posted this 27 October 2017

Thanks for the information. We are now using external IP and it works fine.

Close