Unable to synchronize records between Salesforce and SQL Server

  • 8Views
  • Last Post 5 days ago
0
votes
Jeff Monian posted this 5 days ago

Hello,

I'm having trouble getting the syncronization integration between my salesforce account and a table on my sql server to actually syncronize records. I am trying to send salesforce contacts to a table on the sql server but when I run the integration and it succeeds nothing happens and it says 0 records. I am sure that I am connected to both data sources and am able to query them. I made sure that the salesforce contact attributes were mapped to all of the fields in the tables as well. When I run the syncronization it periodically fails and says 1 record but other times it succeeds with 0 records. Not sure where to go from here.

Thanks!

0
votes
Mariia Zaharova posted this 5 days ago

The main requirement for synchronizing database data is that the primary key columns of the database tables must be autogenerated.

When synchronization is performed for the first time, it does not check whether the records in sources are identical and simply copies data from one side to another and vice versa, and "maps" the original records to their copies in another source. 

When performing synchronization repeatedly, Skyvia synchronizes only data that was changed since the previous synchronization. It uses the fields storing information about when a record was created and modified in cloud applications and creates special tracking tables and triggers in relational databases for data modification tracking.

Please refer to: 

https://skyvia.com/resources/docs/index.html?synchronization_overview.htm

https://skyvia.com/resources/docs/index.html?synchronizing_product_data.htm

 

As for failed rows, you can download a CSV file which contains the list of failed records and the reasons why each of the records failed. The number of failed rows in Run History is a link, and you can click it to download this CSV file. You can find more information in our documentation: https://skyvia.com/resources/docs/error_processing.htm

 

Please tell us if this helps.

Close