Use Zoho CRM API v2

  • 550Views
  • Last Post 19 December 2019
2
votes
Mariusz Kukawski posted this 22 October 2018

Zoho CRM API v2 has much more functionality and has bigger limits than API v1.

Can you please start supporting this for Skyvia?

More details :

https://www.zoho.com/crm/help/api/deprecation-transition-announcement.html

  • Supported by
  • Sid Burton
  • cpala
Order By: Standard | Newest | Votes
1
votes
Mariia Zaharova posted this 23 October 2018

We are working on Zoho CRM API v2 support at the moment. We will post here when it is available.

 

Best regards,

Mariia

  • Supported by
  • Mariusz Kukawski
0
votes
Mariusz Kukawski posted this 15 February 2019

API v1 is already deprecated, can you please add support for v2?

0
votes
Mariia Zaharova posted this 18 February 2019

Hi Mariusz!

 

We are working hard to release Zoho CRM API v2 support as soon as possible, however, we can't tell you an exact timeframe regarding this for now.

We will post here the results as soon as possible.

 

 

Best regards,

Mariia

0
votes
Mariusz Kukawski posted this 09 July 2019

The deadline to turn off the Zoho API V1 is approaching soon and still Skyvia is on old API. Can you please migrate?

We don't want to leave a situation that sync will stop working because of this delay

0
votes
Mariia Zaharova posted this 10 July 2019

Hi Mariusz!

 

We are in the process of migrating to Zoho CRM API v2.

The API v2 support is going to be released before API v1 turning off.

We will definitely notify you as soon as it is done.

 

Best regards,

Mariia

0
votes
Sid Burton posted this 04 August 2019

Hi Mariia,

Any good news regarding ZohoCRM API V2? Maybe an approximate date?

0
votes
Mariia Zaharova posted this 09 August 2019

Hi!

 

Sorry for the delayed response.

We are going to release new Skyvia version with Zoho CRM API v2 support in 2-3 weeks.

We will post here when new version of Skyvia is released.

 

Best regards,

Mariia

0
votes
Mariusz Kukawski posted this 18 September 2019

Hi, I got a message from Zoho today:

"Looks like you are still using V1 version of our API. This version was deprecated on Dec 31, 2018 and will reach end-of-life(EOL) on Dec 31, 2019. We strongly recommend you migrate to the new and improved API 2.0."

Can you please prioritize this?

0
votes
Mariia Zaharova posted this 19 September 2019

Thank you for contacting us once again!

 

We apologize for the long wait. We're on the final stage of development and testing. 

 

We'll let you know once we release Zoho CRM API V2 support.

 

Best regards,

Mariia

1
votes
Mariia Zaharova posted this 10 October 2019

Zoho CRM API V2 support is available in Skyvia now. Feel free to test it and contact us in case of any questions.

 

Best regards,

Mariia

  • Supported by
  • Mariusz Kukawski
0
votes
Presidents Institute posted this 11 October 2019

Glad to see the API V2 is finally available!
However when trying to authenticate, i login with my Zoho login, and then i get to a page saying:

ERROR_invalid_client

Tried in both Firefox and Chrome, and also in an incognito tab.
I'm using crm.zoho.eu as my domain.

0
votes
Mariusz Kukawski posted this 11 October 2019

Thank you Mariia for the new implementation

I was able to use the new API.

I tested and found some issues, listed below by priority:

1. Write operations seem to use "Bulk" API, no matter how many records are there to synchronize. For small integrations (but frequent) this is eating a lot of API quota (e.g. writing 10 records eats 500 API credits, vs. in individual updates would eat only 1). This is probably a blocker for small but frequent integrations. Is there way to have a choice to use individual update endpoint vs. Bulk API?

2. If the module contains "File Upload" field type, Skyvia's meta endpoint is crashing and can't configure the mapping

3. If the module contains "Autonumbered" field, also similar problems

4. If I have checked "Use Display Name For Custom Tables" and seem to have no effect, still see "internal" cryptic names

5. Column mappings are not compatible for the ID's, naming is changed and type changed to INT8 (I guess it's a breaking change in the API itself), so all the Primary key mappings have to be reconfigured. You might consider automatic mapping to backfill for bigger integrations...

 

0
votes
Mariia Zaharova posted this 15 October 2019

ERROR_invalid_client

We are working on this issue. We will post here the results as soon as possible.

 

0
votes
Mariia Zaharova posted this 15 October 2019

Dear Mariusz!

 

Thank you for your feedback.

 

 1. Write operations seem to use "Bulk" API, no matter how many records are there to synchronize. For small integrations (but frequent) this is eating a lot of API quota (e.g. writing 10 records eats 500 API credits, vs. in individual updates would eat only 1). This is probably a blocker for small but frequent integrations. Is there way to have a choice to use individual update endpoint vs. Bulk API?

For writing operations, Bulk API is used - 100 records per 1 API call. Please check: https://www.zoho.com/crm/developer/docs/api/api-limits.html

There is no way to use individual update endpoints. Moreover, in this case, on the contrary, API calls will be consumed faster.

 

 2. If the module contains "File Upload" field type, Skyvia's meta endpoint is crashing and can't configure the mapping

We have reproduced this issue and created a request for our developer's team. I will notify you when it is fixed.

 

3. If the module contains "Autonumbered" field, also similar problems

We cannot reproduce such behaviour. We were able to select a table with auto-number field and perform Export. Could you please specify more details on this issue, e.g. specify the name of the module with which this issue occurs, send us some screenshots with the error, etc.

 

 4. If I have checked "Use Display Name For Custom Tables" and seem to have no effect, still see "internal" cryptic names

We cannot reproduce such behaviour. After changing this setting and saving the connection, metadata is refreshed and names are changed. So please make sure that after selecting this checkbox, metadata is refreshed: http://prntscr.com/pjl3t7

 

5. Column mappings are not compatible for the ID's, naming is changed and type changed to INT8 (I guess it's a breaking change in the API itself), so all the Primary key mappings have to be reconfigured. You might consider automatic mapping to backfill for bigger integrations...

Yes, this behaviour is related to Zoho API v2, not Skyvia. Unfortunately, we cannot automatically avoid such situations due to significant differences in the API v1 and v2.

 

Best regards,

Mariia

0
votes
Mariia Zaharova posted this 22 October 2019

Dear Mariusz!

 

2. If the module contains "File Upload" field type, Skyvia's meta endpoint is crashing and can't configure the mapping

 

We have fixed the issue, please check it and let us know the results.

0
votes
Mariia Zaharova posted this 22 October 2019

ERROR_invalid_client

We have made changes that should fix the issue. Please try again and let us know the results.

0
votes
Presidents Institute posted this 28 October 2019

Hi Skyvia // Mariia

The ERROR_invalid_client has now been fixed, and I'm now logged in, and can see the different modules.

However, now none of my queries are working - either the ones still using API v1, but also the new ones using API v2
The error i get now is HTTP 409, when ever i try to execute a query.

Complete error message:
"NetworkError: Connection failure due to HTTP 409"

0
votes
Presidents Institute posted this 30 October 2019

Hello again,

The HTTP 409 error is now gone - for reasons i don't know, but i figured that you might have changed something in the backend.

Anyway, new solutions never comes without new problems.
I have 1 query that i used to run in API v1, that doesn't work in API v2, and I have a suspicion that the reason might be that i use a DateTime field in my filter. That is the only query that doesn't work, and it's the only one that uses a DateTime field in it's filter.

The query is quite simple, i want the owner name, and the "converted date" (custom date time field) on a list.
My one and only filter is that the "converted date"-field, must not be null

I have tested this by changing my filters to something else, and then I'm succesful. If i use another datetime field as filter, the same thing happens, so I'm pretty sure that's the reason.

The error i recieve is: Exception: Timeout: https://app.skyvia.com/api/connections/{QUERY_ID}/query

Are you aware of this? If yes, do you have an ETA on when this is fixed?
It's still working using API v1, so I'll keep running it that way, until i hear from you. Using DateTime fields as filters, is a must!

0
votes
Mariia Zaharova posted this 31 October 2019

Hello!

The error i recieve is: Exception: Timeout: https://app.skyvia.com/api/connections/{QUERY_ID}/query

Are you aware of this? If yes, do you have an ETA on when this is fixed?

No, unfortunately, we could not reproduce such an issue. Could you please specify exact definition of this custom field in your Zoho CRM (send us screenshots, etc.) and specify an exact query that fails with Ver2 and works with Ver1.

 

Thank you and looking forward to your reply.

 

Best regards,

Mariia

 

0
votes
cpala posted this 09 December 2019

I am still seeing v1 API usage on the Zoho side, originating from Skyvia's IP address:

On the Skyvia side, it suggests my connection is already using v2 API. What is going on? 

This has me worried that the integration task will fail on Dec 31 - it's very clearly using/consuming outdated API calls. 

0
votes
Mariia Zaharova posted this 09 December 2019

Hello!

 

Due to the fact that initially, your connection was configured to API Ver1, the transition to API Ver2 might have some issues. Metadata of Zoho CRM API Ver1 and Ver2 differ for many objects/fields, so for API Ver2, we recommend creating a completely new Zoho CRM connection with API Ver2 and new Replication packages (in order to create target database tables according to the new source objects) or perform full replication (reset LastSyncTime and re-create tables) on current packages.

 

Best regards,

Mariia

0
votes
cpala posted this 11 December 2019

Thanks Mariia. My sync tasks mysteriously broke some time after writing the post, so I wonder if your team looked at my account?

In any case, Skyvia may consider making users of the Zoho connector aware of the changes. The connection properties showing "ver2" instead of "ver1" was quite misleading in my case - all the table/field name changes that come with the v2 API caused a few headaches my end. 

0
votes
Mariia Zaharova posted this 11 December 2019

My sync tasks mysteriously broke some time after writing the post, so I wonder if your team looked at my account?

 

We looked at your account, but no changes were made to your packages from our side. Please specify a package name, run number, etc., so that we are able to check logs.

In any case, Skyvia may consider making users of the Zoho connector aware of the changes. 

 

Sure, we will consider this for future updates.

 

Best regards,

Mariia

0
votes
Katsuhiro Kuwahara posted this 17 December 2019

Changing the API of Zoho CRM to V2 caused a lot of trouble.

I use Zoho CRM in Japanese. There was no problem when the API was V1, but there was a problem with V2.

The contents are as stated below.

When I try to run Replication, I get the following error:

The source object 'CustomModule8' has neither 'Created Time' nor Modified Time column and cannot be used when the 'Incremental Updates' check box is selected.

It seems that "Create Time" and "Modified Time" did not recognize Skyvia because the item name on Zoho CRM is in Japanese.

I can't do anything on Zoho, so what can I do on the Skyvia side?

0
votes
Dmitriy Muzurov posted this 17 December 2019

Hello Katsuhiro,

Thank you for submitting a ticket with us.

Please clear Metadata Cache in your Zoho CRM connection settings:

Let us know if that works.

We are looking forward to hearing from you.

0
votes
Dmitriy Muzurov posted this 17 December 2019

Dear Katsuhiro,

It seems the required columns Created Time and Modified Time are not selected for the package with incremental updates.

They must be selected for incremental updates to work.

Let us know if you have any questions.

0
votes
Katsuhiro Kuwahara posted this 18 December 2019

Hello Dmitrly,

Thank you for your answer.

This event has not been solved by the above measures. The Zoho table that was originally connected with V1 is account, which has both “Created time” and “Modified time”. Of course, the source has not changed. When the API is changed to V2, in the item information acquired from Zoho, “Created time” and “Modified time” are acquired in Japanese, such as “作成日時” and “更新日時”. Incremental updates will not work with this status, so there may be something in the API acquisition settings etc.

 

0
votes
Dmitriy Muzurov posted this 19 December 2019

Dear Katsuhiro,

Thank you for clarification.

We managed to reproduce the issue.

It seems, when changing language, Zoho CRM translates Created Time and Modified Time fields to Japanese while leaving other system fields in English.

Unfortunately, this issue can't be addressed currently.

The only variant is to keep these columns in English.

Should you have any questions, do not hesitate to contact us back.

Close