Using up allowed SFDC API calls but cannot disable integrations

  • 54Views
  • Last Post 06 April 2018
0
votes
Sven posted this 21 March 2018

Hi. I have created integrations with too frequent schedules so the allowed number of API calls to Salesforce hit the limit in Salesforce. This means that Skyvia runs fail, get error message "TotalRequests Limit exceeded." So I want to disable integrations and change thir schedules to prevent this. But I cannot save changes in Skyvia as the API limit is reached..

This is the error message I get:

Error getting objects!

TotalRequests Limit exceeded.

 

How do I get out of this?

Order By: Standard | Newest | Votes
0
votes
Mariia Zaharova posted this 22 March 2018

Dear Sven, 

We have contacted you by email.

 

Best regards, 

Mariia

0
votes
Sven posted this 04 April 2018

Thanks. It resolved itself eventually when the Salesforce API limit opened up (as the limit is usage per last 24h) as luckily enough there was a window where no new integrations were scheduled. But it caused me quite a headache as it was not possible to disable / unschedule Skyvia integrations while the Salesforce API limit was in force, so had any Skyvia integration fired during that time then I would have been competely stuck. So you really need to ensure that Skyvia integrations can be disabled / unscheduled even though Salesforce API limit is hit.

0
votes
Mariia Zaharova posted this 05 April 2018

But it caused me quite a headache as it was not possible to disable / unschedule Skyvia integrations

It is possible to disable or change schedule for not running packages. As for the running packages, yes, currently, when you click Cancel, the current task execution continues. After the completion of the current task, the package stops. If there are more tasks in the package, they are not executed. If your package contains only one task, the cancel operation takes as much time as it is required for the package completion.

We will consider the possibility to cancel running tasks immediately in the future, however, we can't tell you any timeframe regarding this at the moment. You can contact us anytime you need help.

 

Thank you for using Skyvia!

0
votes
Sven posted this 05 April 2018

OK thanks. But that only answers part of my question. The main issue was that I could not Unschedule a package (even if it was not running at the time), because apparently saving changes to a package generates an API call to Salesforce. And Salesforce would block that since we had hit the API limit. This means that I could not make changes to Skyvia packages as long as Salesforce was blocking API calls. And since we have several packages on schedule, they just kept starting and using up the API call allowance. So I got into a loop I could not get out of.

0
votes
Mariia Zaharova posted this 06 April 2018

The main issue was that I could not Unschedule a package (even if it was not running at the time), because apparently saving changes to a package generates an API call to Salesforce. And Salesforce would block that since we had hit the API limit. This means that I could not make changes to Skyvia packages as long as Salesforce was blocking API calls. And since we have several packages on schedule, they just kept starting and using up the API call allowance. 

 

In fact, Skyvia does not send any requests to Salesforce (or any other data source being used in the package) after making any changes to its schedule and saving the package.

Let's clarify these details:

- packages were not in the Queued or Running state, correct?

- you were able to open Package Editor, correct?

- you were able to change or disable schedule in the Schedule section of Package Editor, correct?

- you were not able to save changes to the package, correct? When you clicked Save you got an error, correct?

 

If not, please describe all the steps you performed with all available details.

Close